Author Topic: EDAN35 High Performance Computer Graphics 2017 HT2  (Read 3992 times)

Offline MikeD

  • Full Member
  • ***
  • Posts: 210
Welcome to EDAN35!

Here you can post questions about the course, assignments and project. Pierre and I will monitor the forum.
The lab sign ups are ready, so make a pair and sign up as soon as you can.
If you can't sign up for a lab, you may not be enrolled in the course, so send me an email.

Mike


Offline MikeD

  • Full Member
  • ***
  • Posts: 210
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #1 on: 2017-10-31 15:40:51 »

Offline dat13vlu

  • Newbie
  • *
  • Posts: 6
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #2 on: 2017-11-01 10:52:46 »
Hello, I'm looking for a lab partner, preferreably for the friday lab sessions! My STIL-id is dat13vlu :)
// Vilhelm Lundqvist

Offline Olle Alvin

  • Newbie
  • *
  • Posts: 4
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #3 on: 2017-11-02 16:58:34 »
Hello, I'm looking for a lab partner, preferreably for the friday lab sessions! My STIL-id is dat13vlu :)
// Vilhelm Lundqvist
Hello! Also looking for a lab partner, want to partner up? :)
/Olle Alvin tpi14oal

Offline Pierre Moreau

  • Full Member
  • ***
  • Posts: 201
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #4 on: 2017-11-06 14:03:14 »
In order to build the first assignment, you need to have a look at this post to add some preprocessor definitions and toggle a flag off.

Note that you can add _SILENCE_STDEXT_HASH_DEPRECATION_WARNINGS to the list of preprocessor definitions by doing:
Right-click on your project ->
      Properties ->
      Configuration Properties ->
      C/C++ ->
      Preprocessor and edit "Preprocessor definitions" : in the pop-up dialog, create a new line and write “_SILENCE_STDEXT_HASH_DEPRECATION_WARNINGS” on it, and save

The code will not work with Visual Studio 2017 >= 15.3 due to a change in how debug information is stored in object files, making the DLLs shipped with the project incompatible.

Offline heb12mst

  • Newbie
  • *
  • Posts: 1
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #5 on: 2017-11-06 20:18:54 »
Hello! Anyone in need of a lab partner?  :)
//Stephanie Mirsky heb12mst

Offline erikm

  • Newbie
  • *
  • Posts: 4
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #6 on: 2017-11-09 10:20:54 »
Anyone managed to solve this error while building?
Code: [Select]
LNK1103 debugging information corrupt; recompile module

Offline Pierre Moreau

  • Full Member
  • ***
  • Posts: 201
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #7 on: 2017-11-09 11:36:25 »
Anyone managed to solve this error while building?
Code: [Select]
LNK1103 debugging information corrupt; recompile module

I am assuming you are compiling with Visual Studio 2017 (version >= 15.3), in which case see my comment a few posts above.

If you want to work on your own computer, you should use Visual Studio 2015 which you can get here; you will need to join the free “Dev Essentials” program, which involves creating a Microsoft account. (which should be free as well).
Otherwise, use the lab computers.

Note: Apparently, it might be a bug in VS 2017’s compiler or linker, which would be fixed with Visual Studio 2017 15.5 preview 2. It doesn’t seem to require any account to download it and should happily live side-by-side with a release version of 2017. I’ll try that this afternoon to check whether it works or not.

Offline Pierre Moreau

  • Full Member
  • ***
  • Posts: 201
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #8 on: 2017-11-09 14:29:43 »
Note: Apparently, it might be a bug in VS 2017’s compiler or linker, which would be fixed with Visual Studio 2017 15.5 preview 2. It doesn’t seem to require any account to download it and should happily live side-by-side with a release version of 2017. I’ll try that this afternoon to check whether it works or not.

I just tried running the latest preview of VS 2017 (15.5, preview 3), and everything worked fine with it. So, either
  • Install the VS 2017 preview;
  • Install VS 2015;
  • Work on the lab computers.

Offline erikm

  • Newbie
  • *
  • Posts: 4
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #9 on: 2017-11-12 10:49:08 »
Note: Apparently, it might be a bug in VS 2017’s compiler or linker, which would be fixed with Visual Studio 2017 15.5 preview 2. It doesn’t seem to require any account to download it and should happily live side-by-side with a release version of 2017. I’ll try that this afternoon to check whether it works or not.

I just tried running the latest preview of VS 2017 (15.5, preview 3), and everything worked fine with it. So, either
  • Install the VS 2017 preview;
  • Install VS 2015;
  • Work on the lab computers.

Thanks for your reply. I did use VS 2017 but I couldn't get VS 2015 to work either... But then I tried the preview and it worked fine right away. So if anyone's still struggling, try the preview.

Offline Pierre Moreau

  • Full Member
  • ***
  • Posts: 201
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #10 on: 2017-11-13 09:27:54 »
For students that did not take the intro course (EDAF80) and are planning to work on the lab computers:
  • You have to put the whole code under a folder named "Program" if you are working on the C drive (which is recommended) on the lab computers. See http://forum.student.lth.se/index.php/topic,12059.msg15772.html#msg15772 for more details.
  • You will also need to manually set the “TMP” environment variable for the whole session. To do that, press the Windows key, then type “user”, select the first option (“User Accounts”) in the list, which should bring you to one of the “Control Panel” interface. On the left side, select “Change my environment variables”, and edit the %TMP% (not %TEMP%) variable to point to the “Temp” folder sitting next to “code” and “build”. Log out and log in again, restart Visual Studio and it should compile.
Other information about how to run CMake and build from Visual Studio, can be found in the README file (on GitHub or in the folder you downloaded from GitHub).

Offline dat13dbj

  • Newbie
  • *
  • Posts: 1
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #11 on: 2017-11-16 16:22:43 »
Hello,
We are trying to run the project. We have generated the project through Cmake, but the gml libraries seem to not be found (even though we see it is in the build folder). We tried to follow your 2nd tip:
Quote
You will also need to manually set the “TMP” environment variable for the whole session. To do that, press the Windows key, then type “user”, select the first option (“User Accounts”) in the list, which should bring you to one of the “Control Panel” interface. On the left side, select “Change my environment variables”, and edit the %TMP% (not %TEMP%) variable to point to the “Temp” folder sitting next to “code” and “build”. Log out and log in again, restart Visual Studio and it should compile.
But when we run we get an error message: "The program can't start because assimp-vc140-mt.dll is missing from your computer. Try reinstalling the program to fix this problem.". We can see in Visual studios that the gml includes are marked red, but somehow it builds and then fails at the run like mentioned above.

Offline Pierre Moreau

  • Full Member
  • ***
  • Posts: 201
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #12 on: 2017-11-18 16:09:07 »
But when we run we get an error message: "The program can't start because assimp-vc140-mt.dll is missing from your computer. Try reinstalling the program to fix this problem.".

For some reason, it sometimes does not found the assimp DLL. You have to manually copy it to the “build/src/EDAF80/(Debug|Release)” (depending on the build option you should, debug or release). The DLL can be found (IIRC) under “build/assimp/build/code/”.

Offline Pierre Moreau

  • Full Member
  • ***
  • Posts: 201
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #13 on: 2017-11-20 16:14:29 »
There was an issue with the falloff angle for the lights: it shouldn’t be 45°, but more 37° (see this patch for what you need to change).

It seems that the mesh for the cone does not represent a cone with a half-angle of 45°. You can check by yourself:
  • Uncomment this piece of code;
  • Implement the angular falloff as an all or nothing: either you are less than the falloff angle and you have full intensity, or you are over it and there is no light at all;
  • Stop the lights (having only one light might make it easier to see), and turn a bit around the light: if the falloff angle was less or equal to the cone’s half-angle, the lit areas should not change depending on your point of view. This was not the case when using 45° as the falloff angle, therefore the half-angle was smaller than 45°. By trial and error, the half-angle seems to be around 37°.

Offline MikeD

  • Full Member
  • ***
  • Posts: 210
Re: EDAN35 High Performance Computer Graphics 2017 HT2
« Reply #14 on: 2017-11-30 13:10:50 »
Wednesday lecture, Nov 30th, is moved to E:2116.
It appears there is a thesis defence in E:1406.