Author Topic: EDA221 - Introduction to 3D 2014 HT1  (Read 25730 times)

Offline MikeD

  • Full Member
  • ***
  • Posts: 210
EDA221 - Introduction to 3D 2014 HT1
« on: 2014-08-22 11:04:11 »
Welcome to the Computer graphics: Introduction to 3D discussion forum!  :)

Here you may ask questions about the labs or other issues. Teachers/assistants will be present here, but students are highly encouraged to participate.

Course-related announcements might pop up here as well, so make sure to stop by on a regular basis.

Editions from previous years (lots of useful stuff):
2013 forum: http://forum.student.lth.se/index.php/topic,1105.0.html
2012 forum: http://forum.student.lth.se/index.php/topic,1057.0.html
2011 forum: http://forum.student.lth.se/index.php/topic,999.0.html
2010 forum: http://forum.student.lth.se/index.php/topic,929.0.html
« Last Edit: 2014-08-28 10:57:43 by MikeD »

Offline bondi

  • Newbie
  • *
  • Posts: 15
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #1 on: 2014-09-04 14:48:00 »
Någon som behöver en partner för uppgifterna? :)

Anyone needing a partner for the assignments? :)

Offline Saša

  • Newbie
  • *
  • Posts: 1
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #2 on: 2014-09-04 15:39:39 »
Behöver du fortfarande en partner? I så fall samarbetar jag gärna!

Offline bondi

  • Newbie
  • *
  • Posts: 15
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #3 on: 2014-09-04 16:11:32 »
Behöver du fortfarande en partner? I så fall samarbetar jag gärna!

Det gör jag, så då kör vi tillsammans! :D
Lägg till mig på facebook, heter Pontus Bondi Eriksson!

Offline MikeD

  • Full Member
  • ***
  • Posts: 210
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #4 on: 2014-09-05 10:14:50 »
You can sign up for the lab sessions here :
https://sam.cs.lth.se/LabsSelectSession?occasionId=341

Offline MikeD

  • Full Member
  • ***
  • Posts: 210
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #5 on: 2014-09-05 13:48:19 »
If you are getting the RenderChimp code to work on OSX, check out Jacob's first reply on the 2013 forum.

Offline scr

  • Newbie
  • *
  • Posts: 3
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #6 on: 2014-09-06 10:55:22 »
Hej,
försöker få RenderChimp att fungera på OS X 10.9.4. Har installerat SDL och SDLimage efter vad som stod i forumet för 2013.

Jag får dock detta felmeddelandet "No architectures to compile for (ARCHS=x86_64, VALID_ARCHS=i386)."

Mina build settings i architecture är:

Additional SDKs:
Architectures: Standard Architectures (64-bit Intel) (x86_64)
Base SDK: Latest OS X (OS X 10.9)
Build Active Architecture Only: No
Supported Platforms: OS X
Valid Architectures: i386

Har googlat utan framgång så om någon vet vad som är fel får ni gärna hjälpa till!


Offline MikeD

  • Full Member
  • ***
  • Posts: 210
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #7 on: 2014-09-06 12:35:40 »
Try setting architecture to 32-bit Intel (i386)
RC still has 32bit dependencies.

Hej,
försöker få RenderChimp att fungera på OS X 10.9.4. Har installerat SDL och SDLimage efter vad som stod i forumet för 2013.

Jag får dock detta felmeddelandet "No architectures to compile for (ARCHS=x86_64, VALID_ARCHS=i386)."

Mina build settings i architecture är:

Additional SDKs:
Architectures: Standard Architectures (64-bit Intel) (x86_64)
Base SDK: Latest OS X (OS X 10.9)
Build Active Architecture Only: No
Supported Platforms: OS X
Valid Architectures: i386

Har googlat utan framgång så om någon vet vad som är fel får ni gärna hjälpa till!

Offline scr

  • Newbie
  • *
  • Posts: 3
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #8 on: 2014-09-06 19:27:16 »
I changed that but got some new problems instead...
Here is a print screen of the error messages:

Try setting architecture to 32-bit Intel (i386)
RC still has 32bit dependencies.

Hej,
försöker få RenderChimp att fungera på OS X 10.9.4. Har installerat SDL och SDLimage efter vad som stod i forumet för 2013.

Jag får dock detta felmeddelandet "No architectures to compile for (ARCHS=x86_64, VALID_ARCHS=i386)."

Mina build settings i architecture är:

Additional SDKs:
Architectures: Standard Architectures (64-bit Intel) (x86_64)
Base SDK: Latest OS X (OS X 10.9)
Build Active Architecture Only: No
Supported Platforms: OS X
Valid Architectures: i386

Har googlat utan framgång så om någon vet vad som är fel får ni gärna hjälpa till!

Offline Kenan

  • Newbie
  • *
  • Posts: 2
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #9 on: 2014-09-07 20:55:37 »
Hi!

Anyone needing a partner?

Någon som behöver en partner?

Offline MikeD

  • Full Member
  • ***
  • Posts: 210
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #10 on: 2014-09-08 10:45:41 »

For OSX 10.9, you need to make the following changes.

In GLee.h replace :
           typedef ptrdiff_t GLintptrARB;
      typedef ptrdiff_t GLsizeiptrARB;

with :
           typedef long GLintptrARB;
      typedef long GLsizeiptrARB;

and replace :
   typedef int GLhandleARB;
with :
        typedef  void* GLhandleARB;

and in RendererGL.cpp add a cast to (GLint) for GL_VERTEX_SHADER and GL_FRAGMENT_SHADER
  id = (GLint) glCreateShaderObjectARB(GL_VERTEX_SHADER);

 id = (GLint) glCreateShaderObjectARB(GL_FRAGMENT_SHADER);


I changed that but got some new problems instead...
Here is a print screen of the error messages:

Try setting architecture to 32-bit Intel (i386)
RC still has 32bit dependencies.

Hej,
försöker få RenderChimp att fungera på OS X 10.9.4. Har installerat SDL och SDLimage efter vad som stod i forumet för 2013.

Jag får dock detta felmeddelandet "No architectures to compile for (ARCHS=x86_64, VALID_ARCHS=i386)."

Mina build settings i architecture är:

Additional SDKs:
Architectures: Standard Architectures (64-bit Intel) (x86_64)
Base SDK: Latest OS X (OS X 10.9)
Build Active Architecture Only: No
Supported Platforms: OS X
Valid Architectures: i386

Har googlat utan framgång så om någon vet vad som är fel får ni gärna hjälpa till!

Offline dscheibe

  • Newbie
  • *
  • Posts: 3
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #11 on: 2014-09-08 13:03:33 »
Hello.  I have downloaded SDL.frameworks version 1.2.15 and SDL_image.frameworks version 1.2.12 for mac OSX and put them both into my /Library/Frameworks folder.  I have also updated the changes mentioned above regarding Glee.h and GLint casting.  However now I am getting an error in PlatformOSX.cpp of "SLD_image/SDL_image.h" file not found.  I've tried to change this to simply SDL_image.h but it cannot find that file and I have tried renaming the SDL_image.h file in the SDL_image.frameworks but that doesn't work either.  Anyone else running MAC OSX 10.9.1 and Xcode 5.1.1 having the same problem or know how to fix it? thank you.

Offline scr

  • Newbie
  • *
  • Posts: 3
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #12 on: 2014-09-08 14:14:43 »
Seems like it works for me now so maybe this will solve the problem.

In the bar to the left with the file system, navigate to frameworks->linked frameworks. At first my "SDL_image.frameworks" was marked red and the path/location was wrong. So if this is the case then change the path/location to "/Library/Frameworks/SDL_image.framework". This can be done in the bar to the right when you mark "SDL_image.frameworks".

Hello.  I have downloaded SDL.frameworks version 1.2.15 and SDL_image.frameworks version 1.2.12 for mac OSX and put them both into my /Library/Frameworks folder.  I have also updated the changes mentioned above regarding Glee.h and GLint casting.  However now I am getting an error in PlatformOSX.cpp of "SLD_image/SDL_image.h" file not found.  I've tried to change this to simply SDL_image.h but it cannot find that file and I have tried renaming the SDL_image.h file in the SDL_image.frameworks but that doesn't work either.  Anyone else running MAC OSX 10.9.1 and Xcode 5.1.1 having the same problem or know how to fix it? thank you.

Offline dscheibe

  • Newbie
  • *
  • Posts: 3
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #13 on: 2014-09-08 14:19:12 »
It shows it as a valid path. It should have Linked Frameworks->SDL_image.frameworks->Frameworks and Headers-> (in Headers) SDL_image.h and only this header.  This is what mine shows, is that correct?

Seems like it works for me now so maybe this will solve the problem.

In the bar to the left with the file system, navigate to frameworks->linked frameworks. At first my "SDL_image.frameworks" was marked red and the path/location was wrong. So if this is the case then change the path/location to "/Library/Frameworks/SDL_image.framework". This can be done in the bar to the right when you mark "SDL_image.frameworks".

Hello.  I have downloaded SDL.frameworks version 1.2.15 and SDL_image.frameworks version 1.2.12 for mac OSX and put them both into my /Library/Frameworks folder.  I have also updated the changes mentioned above regarding Glee.h and GLint casting.  However now I am getting an error in PlatformOSX.cpp of "SLD_image/SDL_image.h" file not found.  I've tried to change this to simply SDL_image.h but it cannot find that file and I have tried renaming the SDL_image.h file in the SDL_image.frameworks but that doesn't work either.  Anyone else running MAC OSX 10.9.1 and Xcode 5.1.1 having the same problem or know how to fix it? thank you.

I also need a partner if anyone else does. I'm a student at UCLA in California and I don't speak any Swedish.  My name is David Scheibe.
« Last Edit: 2014-09-08 17:18:45 by dscheibe »

Offline Kenan

  • Newbie
  • *
  • Posts: 2
Re: EDA221 - Introduction to 3D 2014 HT1
« Reply #14 on: 2014-09-08 19:44:08 »
Hi!
I'm looking for a partner as well and also operate on OS X. Got mine to work after reading up in the forum, I could help you tomorrow after the lecture if don't get it to start. Because I had the same problem. If you are up for partnership my name is Kenan Sulejmanovic. I'm student of LTH  :D